Datacake - Incomplete Data Display for Some Devices – Details zu Vorfällen

Alle Systeme funktionieren

Incomplete Data Display for Some Devices

Gelöst
Funktionsfähig
Aufgetreten am vor 13 TagenDauerte 4 Tage

Betroffen

Web Application

Funktionsfähig aus 11:56 AM zu 7:43 AM

Reports

Funktionsfähig aus 11:56 AM zu 7:43 AM

Aktualisierung
  • Gelöst
    Gelöst

    The issue causing incomplete historical data display for certain devices has been resolved. All data is now fully accessible across dashboards and the application.

    What Happened:

    We identified an issue where historical data from early to mid-September 2025 was not appearing in queries and visualizations for specific devices in certain retention plans. The root cause was traced to a bug in our time-series database software related to Bloom filters on compressed data chunks. These filters were incorrectly marking data as non-existent, causing the database to skip chunks that actually contained the requested data.

    Resolution:

    Our database vendor Timescale identified and fixed a software bug in their compression filtering logic. The fix has been applied to our database instance, and all queries now return complete and accurate results.

    Data Safety:

    All data remained safely stored throughout this incident. No data was lost or corrupted - it was simply not being returned in certain filtered queries due to the database software bug.

    We appreciate Timescale's quick response in identifying and resolving this issue. We apologize for any confusion or inconvenience this may have caused and thank you for your patience.

  • Analyse
    Analyse

    We are currently experiencing an issue where dashboards and other parts of the application may show incomplete historical data for certain devices in specific retention plans.

    Data from early to mid-September 2025 may not be visible in queries and visualizations for affected devices, though all data remains safely stored and intact.

    We have identified the root cause as a database indexing issue with our external database vendor and are working directly with their support team to resolve it.