Datacake - MQTT processing delays – Incident details

MQTT processing delays

Resolved
Degraded performance
Started 21 days agoLasted about 7 hours

Affected

MQTT Server

Degraded performance from 5:24 AM to 12:06 PM

Updates
  • Resolved
    Resolved

    Earlier this morning, we identified an incident where outgoing MQTT messages began queueing up, causing delays in message delivery. Our operations team immediately implemented countermeasures by adjusting infrastructure configurations, which successfully increased queue processing rates.

    The backlog has now been completely cleared, and after a thorough monitoring period, we can confirm the system is operating normally. All MQTT services have returned to optimal performance levels.

    We apologize for any inconvenience this may have caused. Our engineering team is actively working on improvements to our MQTT infrastructure to prevent similar incidents in the future.

  • Investigating
    Investigating

    Our MQTT broker is experiencing processing delays. No data has been lost, and the system should be caught up shortly.