Resolved
Performance degradation

Started
November 16, 2023 at 12:24 PM
Status
Resolved after about 1 hour

Impact

Degraded performance
Affected
Web Application
  • Resolved
    Resolved

    We had received reports from monitoring tools and customers that there had been increased latencies and occasional timeouts for customers from Europe and Asia.

    Since then, reported latencies have stabilized. Thank you for your patience. If any issues persist, please contact support.

  • Investigating
    Investigating

    We are investigating increased latencies with the API.